Issuance services degradation
Resolved
Jul 6, 2026 at 12:40pm UTC
Root Cause Identified and Mitigated
Our engineering team has completed the Root Cause Analysis (RCA) for the recent service degradation affecting certificate issuance. The issue was traced back to an unprecedented concurrency anomaly within our backend infrastructure.
We have successfully applied the necessary adjustments to resolve the issue and prevent it from recurring. All certificate issuance services are fully restored and operating normally. We will continue to monitor system performance closely to ensure sustained stability.
Affected services
Created
Jul 6, 2026 at 10:30am UTC
The certificate issuance systems experienced a degradation from 11:45 to 12:00, followed by a severe degradation between 12:00 and 12:15. Please note that only the certificate issuance services were affected, while TSA and remote signature services remained fully operational. As of 12:15, the situation has been completely resolved and everything is operating normally again.
We are monitoring the situation and will provide the next update in 2 hours.
Affected services